Skip navigation

Monthly Archives: agosto 2008

He aqui otro recordatorio de como instalar Rails en Ubuntu esta vez en la version Hardy Heron. Pareciera que cada cambio de version hay algo que cambia y que uno pasa un buen rato averiguando que paso antes de poder ser productivo una vez mas. Bueno aqui va de nuevo…

Instalar Prerrequisitos

$ sudo apt-get install build-essential

Instalar Ruby y Librerias de compilacion

$ sudo apt-get install ruby1.8-dev ruby1.8 ri1.8 rdoc1.8 irb1.8 libreadline-ruby1.8 libruby1.8 libopenssl-ruby sqlite3 libsqlite3-ruby1.8 swig libsqlite3-ruby libsqlite3-dev libyaml-ruby

Instalar Gems

$ wget http://rubyforge.org/frs/download.php/38646/rubygems-1.2.0.tgz
$ tar -xvf rubygems-1.2.0.tgz
$ cd rubygems-1.2.0.tgz
$ ruby setup.rb

Instalar Rails, Mongrel y Sqlite3

$ sudo gem install rails
$ sudo gem install mongrel
$ sudo gem install sqlite3-ruby

Y eso es todo.... :)